How to Fix DTMF Tone Issue in iOS 8 Devices

Lot of users reported about this problem. They can dial into conference calls. But when they enter the code, conference bridge does not recognize the input (DTMF tones) – iPhone 6 (ios 8). But this problem not happened in iOS 7 devices like iPhone 5 with iOS 7.
So how to fix this issue?
According to Sprint customer service,
Step 1: First turn on the home Wi-Fi.
Step 2: Connect your iOS Device (iPhone, iPad) to the Wi-Fi .
Step 3: Move to a strong Wi-Fi connection zone.
Step 4: Tap you iPhone. Also Tap keypad if necessary.
Step 5: Dial  ##CLEAR# (##25327#)
Step 6: Tab call in your iPhone
Step 7: Press ok in  Resetting Subscriber settings prompt and allow the radio to reset.
If you find any other solution for this problem, do let us via comment.
Also read other iOS 8 issue related articles like “iPhone 6 slow Wi-Fi issue“, “No service and touch id issue in iOS 8.0.1” and “car Bluetooth connectivity issue in iPhone 6“.

4:06 pm

16 responses to How to Fix DTMF Tone Issue in iOS 8 Devices

The DMTF issues seems to be caused by using LTE Voice on the iPhone 6. I was able to resolve this issue by changing my LTE settings.
Go to: Settings->Cellular->Enable LTE->
Change the setting from Voice and Data to Data Only
Reboot your phone.
Problem Solved!!
Thank you,
Michael Gardiner

I recently had this problem on my iPhone6 with my bank and my credit card company. My software version is current (IOS 9.0.2). I'm right next to my router and have a strong wifi signal. If the phone is making wifi calls, the tones weren't recognized, but if I was only connected to my carrier (T-Mobile) the tones worked. Then, I noticed that I had turned the setting on for my phone to function as a wi-fi hotspot. Once I toggled this to off, the tones worked even when the phone was on wifi. I tried toggling the hotspot off and on several times, and the tones always failed when it was on, and always went through when it was off. I don't know if this is a quirk or a security feature. But I definitely recommend checking into your wifi and/or hotspot settings.

I checked all of the settings suggested above and tones are still not recognized by our business phone system. (Cannot dial and extension).
Any other suggestions?

Michael Gardiner's solution worked for me on my iPhone 6S Plus. I'd called Apple several times and the Level 2's to whom I spoke were clueless. One wanted me to to wipe and restore the phone but to call T Mobile first. I'd transferred to T-Mobile when I got this new phone on Sept 25th and didn't know whether the phone or T-Mobile was causing the problem. It is clearly a software issue on the settings on the iPhone. T-Moble asked me to wait three days for an answer from their tech team. My phone was not able to send a signal to several important phone numbers that won't take voice input only the numerical input, so I was paralyzed. But changing the LTE settings to Data Only and restarting the phone worked for me. Thank you Michael Gardiner.

Yesterday I said that the change from Voice and Data to Data Only solved the problem with the DTMF tones but it only solved it for one phone number. Today I spoke with a Tech Supv at T-Mobie and solved the whole problem. I had this problem with the new iPhone 6S Plus and at the same time I'd switched from AT&T to T-Mobile so troubleshooting was complex. The solution is that my phone was set to call using WiFi and my WiFi signal at home was sketchy, using an old Apple Time Capsule. It's very old. When I turned off WiFi calling my signal went from between 1-2 bars to between 2-4 bars and I was also able to call the remaining automated number that wasn't receiving my DTMF tones. So T-Mobile is sending me on loan for free a very powerful router they recently acquired. This router should boost my WiFi signal at home significantly. I don't usually call those automated phones when I am not at home. I also have a low signal in the stores I frequent, lower on T-Mobile than I had on AT&T, however, while they are checking on that issue, since I don't call automated numbers that require DTMF signals from those stores it doesn't pertain to this problem. Except the low signal seems relevant to the ability to send DTMF.

I've had the same problem. I noticed the post over and turned off my hotspot and i think that's what did it. I'm not on wifi though so i'm not sure if it's just the hotspot setting, wifi setiing or both. but either way that's what happened for me.

This fix does not work on iPhones using the Spring network. Currently, Sprint has no solution to resolve the issue. The settings described above by Michael are not available on a Sprint iPhone.

Have this issue with my iphone 6S. It is VERY irritating. It only effects the emergency system my company uses, and only 1s, 2s, and 3s. I was in a Verizon store and they couldn't help me, so they called tech support. Verizon tech couldn't help so they called in Apple tech on a 3 way call. All the collective minds put together came up with NOTHING. Tried everything including a hard reset. The solution we ended up using was the band aid fix Michael suggested above. I had found that before and brought it to their attention, hoping that could narrow down the source of the issue. Anyways it doesn't actually fix the problem. I was using that "fix" for about a year or so when one morning I was completely unable to make any outgoing calls. I could use data, text, receive calls, but all outgoing created an unavailable message. I reverted the "fix" and it all worked but now I have my original problem back.
I've had no other issues with any other prompts from other companies. The company paid a special tech to come out and work on their system. Problem isn't their system and only effects this model of iphone. I've tried long presses, short, quick double taps, spamming the key, you name it. Very annoyed that this issue has existed so long and apple has yet to fix it.

same exact issue here, iphone 7plus, ios 11.1.3 , sprint. Ive tried the ## clear (no fix) , and on sprint for Mike's answer, we do not have that option ( there is no "enable LTE" nor anything close to those menus/options he suggested, i looked thorugh everything in LTE)
However, it does seem to be correct that this touchtone issue ALWAYS happens when you receive a call (ie inbound call). when you make a call (outbound call), the issue occurs sometimes, but not always.

I have had this issue on IOS11 earlier and much more on IOS 12 both on iphone 7 and a friends iPhone X.
Called Apple Care, the Apple care guy did not have a clue on what I was talking about, he never heard of conferencing solutions like, webex, premium audio.. And best part is he did not know what is DTMF codes.. 🙁 After keeping me on hold for 5 mins, said it is not an Apple issue, could be Microsoft issue and I lost it. Blame everything on Microsoft. Finally said it could be fixed by resetting the phone and reinstalling the SW. Not happy with the solution..
I tried Michael Gardiner's suggestion from April 2015 to switch off the mobile data and restart phone. Issue disappeared. Thank you Michael.

Michael Gardiner, thank you. I have the same problem.
Called everywhere: Apple, mobile operator, company who owns virtual number and nobody cant help.
Your advice works.

DTMF doesn't play well with wifi calling. Turn off Wifi calling in settings under Cellular | Wi-Fi Calling. That will force the phone to use LTE.

I had the same issue where I would dial into a conference bridge ivr and the DTMF tones would not work. I'm on T-Mobile and found two solutions. When it was working the tones sounded slightly tinny at the end. I had bluetooth enabled and switching to my HX101 (with APTX Low Latency) solved the issue (wifi calling enabled), or using my E7 bluetooth headphones (No APTX Low Latency) with wifi calling disabled solved the issue.

The E7 with wifi calling enabled did not work. I'm not sure if the APTX Low Latency had an effect or if it was some other property of the headphones.

Leave a Reply