MS Office icons missing on OS X Yosemite? Here’s how to fix it


Most of the MS office users reported this issue in Apple support community. MS word document icons all turned white on the desktop. But it appears list view, column view and cover view. But not in icon view. Anything lower than the 30×30 icons turned black white icon. But it will worked well on Maverick.

MS office icon issues Mac

Software & Devices : MacBook Pro 2011, OS X Yosemite

SEE ALSO: Legacy Java SE 6 Runtime Popup on Mac OS X Yosemite? fix

Solution 1:-

Close all running applications.

Open Terminal and type the following command.

sudo rm -rf /Library/Caches/com.apple.iconservices.store

Terminal should prompt. Type admin password and hit return. Now reboot Mac.

Solution 2:-

Use Yosemite Cache Cleaner. It will clear all logs.

SEE ALSO : How to flush the DNS cache in OS X Yosemite

Solution 3:-

Delete content and hidden folders from the following cache folders.

/Library/Caches

/System/Library/Caches

/Users/ your user name/Library/Caches

Solution 4:-

Uninstall Microsoft office and re-install it.

Complete guide from Microsoft : http://support.microsoft.com/kb/2398768

SEE ALSO : Problem after OSX Yosemite upgrade?

If you have any other doubts, do let us via comment.

3:24 pm

7 responses to MS Office icons missing on OS X Yosemite? Here’s how to fix it

I went through steps 1, 2 & 4 with no luck and finally got tired and just pasted the correct icon using Cntl I.

I will admit to being a dinosaur since I bought my first mac in 1984 – a 512. I have lost track of how many I have bought since then but currently have 3 macs and a computer by Apple that runs on Yosemite (which is DEFINITELY not a Mac). It has been over a year since apple forced Yosemite on the world and they still are having these types of problems. I only hope that my 2013 Maverick macbook out lives me because I don't want to change from a mac – the choice between Windows and Yosemite will be a hard one to make. Unfortunately, however, it looks like Windows is actually in the lead – who would have thought that was possible during Apple's heyday?

Neither solution 1 or 3 worked for me but I did a version of 2 but using the free programme called 'Oynx' which I downloaded directly from the Titanium Software website. If you choose to try this make sure you check 'Icon services' in the User tab under Cleaning section, by default it is not checked and I think that is what solves the issue.

There are other ideas discussed and tried on an apple discussion thread here:
https://discussions.apple.com/thread/6606121?tstart=0

Leave a Reply