How to Fix USB Modem not Working in OS X Yosemite


USB-Modem not working on iPhone

People who have installed OS X Yosemite on MacBook are facing a problem that their USB modem connectivity issues after installing it.

The following modems are perfectly working with OS X Mavericks. But after upgrading to OS X Yosemite they stopped working.

  • HUAWEI EC315 USB modem
  • Huawei hi-link E3131, E3231
  • ZTE MF190
  • Huawei E303 Mobile Broadband 3g dongle
  • Turkcell VINN ZTE MF667 USB mode
  • mobiconect usb ZTE MF 667

So let’s see how to fix that problem in this article. Go through it completely and solve your issue.

SEE ALSO: Airtel USB Modem not Working with OS X Yosemite, fix

Solution No 1:- Restart your Mac

The First and foremost solution is restarting your Mac. Restarting method will solve most of the common problems that occur in Mac. Since it is related to USB Modem connectivity issues, so you can try this method and solve your problem. For that,

  • Click on the Apple Logo on the top left side of your mac.
  • Choose the Restart option in that.
  • If you left any of the windows unclosed, a pop-up appears to close the opened window or apps.
  • Once you have done that, your Mac will be restarted. That’s it.

Solution No 2:- Install HiLink.zip

  • Download and install this module HiLink.zip
  • The procedures to be done are given on the website page.
  • Since it is a USB modem issue, download and install this HiLink.zip and check whether your problem is solved or not.
  • Many people have said that this solution has solved their problem. So you can also give it a try.

Solution No 3:-

This solution solved the ZTE USB modem connectivity issue. And it is worked out for many people so you can also give it a try.

Step 1: Go to System preferences and select Network.

Step 2: If you see your USB connection name on the left side go to step 4. If you can’t see it, select + icon.

select wifi network mac
Step 3: Then select your interface and set your service name and click the create button.

enter name for new wifi service

Step 4: Now select ZTEUSBModem on the left side and set the following details.

mac modem configuration
Configuration: Default

Telephone Number: #99*
Account Name and Password must be blank. Then select Advanced.

Note : Enter telephone number #99* for GSM or #777 for CDMA.

Step 5: Now set the following options as given here.

mac network modem settings
Vendor: Generic
Model: GPRS(GSM/3G)

Step 6: Click the OK button and connect.

Final verdict:

I think these solutions might have helped you for sure. If it is not solved yet, then contact Apple support and tell your queries with them.

And if you have any doubts or clarifications regarding this article then tell me through the comments section. And keep supporting iPhonetopics.com

4:54 pm

35 responses to How to Fix USB Modem not Working in OS X Yosemite

Hello Arun,
Well i too switched to Yasomite and found out my 3g dongle is not working at all. There were modem interfaces in System Preferences > Network but i deleted those interfaces following other crappy fix for yasomite 3g dongle issue. Now even i plug in the dongle, i dont get any interfaces rather than Ethernet and Wifi. Do you know any ways to get my 3g Dongole interfaces on??
Thankyou already.

I have exactly the same problem than Arun. I delete the zte mf 190 interface and now i dont know how to add it again. Thanks for your help!!

HI There
Thank you so much for this post!! I was struggling for the past 3 days with this issue. ZTE modem working perfectly now.

Thanks for this – worked on my ZTE MF112 on MacBook Pro running Yosemite. Despite being told that the dongle was "incompatible" with the new OS. Told to go and buy a new one – fortunately I tripped over this hint.

Hi. Thanks for your support, but I have not been able to establish a connection yet. The message that appears is "Has not been able to establish a connection with the PPP server"
Help Please.

i get this error "the communication device selected for your connection does not exist. Verify your settings and try reconnecting." I have followed this guide step by step twice, i cannot find a solution.

Hi. I followed the steps but it didn't work. I get an error message saying, "the communication device selected for your connection does not exist. Verify your settings and try reconnecting."
Please help
Thank you

My issue is that after upgrading to 10.10.2, every time I connect my dongle , E303 or others, it eats up my gigabites with a great velocity. In about 10 seconds I lose 1 gigabite. If I don't disconnect it, I have to go and recharge the dongle. Please help me solve this issue. thank you.

Check if any auto update is enabled. Also check Adobe reader updates, bittorrent or utorrent apps is running or not.
Open terminal and type the following command. It will show which program using internet on your Mac.
lsof -P -i -n | cut -f 1 -d " " | uniq

Hi,
I have 10.10.3 OS and i unable to get the options which is shown above for installation of MF667 ZTE usb stick, if any one knows how to install, pl let me know.

Great manual, thanks!
For me in step 5 I had to fill the APN field.
I searched the net with "APN Telenor" (Telenor is my mobile phone provider in Hungary).
I found that the right APN is "online" for Telenor.
I typed that in, and now it works fine for Huawei e303.
Thank you.

Some 3G moderm will cannot fix follow above. You need uninstall all device.
Find & download kext loader.app from google
Then, browse to your usd disk drive > right click open content of your drive.pgk >…find filename.kext
Drap&drop this file to kext loader tab > load kext button.
Wait a few second
Now, go to system preferences> network> + button. You can see 3-4 menu of modem 3g. Select your interface
This fix approve for 10.10.x & 10.11

Hello there,
Could please give me some more specific way to fix this problem. I've tried kext loader.app but still couldn't find my service provider interface. Thank You.

I couldnot get it worked for me ever since i upgraded to El Capitan. I use Huawei E303. Could you please help me, thank you.

i downloaded the OS X El Capitan and now my 8ta dongle refuses to work. When i try to connect it keeps displaying The device has been disconnected or is unavailable. i used the Dongle on another computer and it works. please help.

Hi
I went onto the link and did the download, but on the final step of installation, it says "Installer cannot install the software because there is no software found to install".

For El Capitan, the old method is not working any more.
You need to download a new driver for the modem, as El Capitan does not support it by default.
Search for the driver on the webpage of your phone company, they should provide you the driver if they supplied you with the modem.
My telehone company provided the drivers for their modems on this page, but I think this will not work with your device, just FYI:
https://www.telenor.hu/internet/tudnivalok/eszkozok-letoltesek

My MacBook Pro can't read Huawei Modem after installing El Capitan.
How can i solve that?
Please It can't connect and can't read.
Thanks
Blessings!!!

My 3G wireless modem for broad band internet
HSUPA USB stick
model:MF190A
ZTE CORPORATION
My computer Imac 21.5 os X 10.9.5
i have installed the modem and the interface for zte has come up with the signal strength showing 4 bars. i am able to send and receive messages using the sim card in the modem but when i press connect for internet on the zte interface is saying service is unreachable. please help solve this problem.

i just want to say thank you, you re the best it works immediately i click on connect after going through the set up. keep the good work

Leave a Reply