Fixed: Swipe to Delete Mail Not Working on iPhone, iPad


Some of iPhone and iPad users had reported a problem that whenever they try swiping to delete Mail, the users couldn’t delete it. Here, I am going to share some tricks with you so that you can make use of it and get rid of this serious issue in the best way.
swipe delete email not working
Fix 1: Change your Mail Account Settings.
change mail account settings

  1. Launch Settings.
  2. Select Mail, Contact, Calendars (or) Mail (or) Accounts and Passwords
  3. Then choose your respective Mail account and tap on Advanced.
  4. Find Move Discarded Messages into and then select Deleted Mailbox instead of Archive and check it.
  5. Now you can press the Back button to return to Account Details.
  6. Click Done.
  7. Restart your device.

Fix 2: Delete and then re-setup your email account.
delete mail account

  1. Launch Settings and then select Mail, Contact, Calendars (or) Mail (or) Accounts and Passwords.
  2. You have to choose the mail account that shows the unread message.
  3. Scroll down and then select Delete Account to confirm an action.
  4. Again go back to Settings.
  5. Select Mail, Contacts, Calendars (or) Mail (or) Accounts and Passwords.
  6. and then choose Add Account.
  7. Finally, re-setup your email account again.

See also: Fix: How to Delete All Emails in iOS 11 on iPhone at Once
Fix 3: Keep swipe Archive
keep swipe archive

  1. Swipe on emails and then choose More instead of Archive.
  2. Now tap on Move Message
  3. Finally, select your trash to delete the email.

Hope any of the above fixes will be helpful to you. If you know any other solution to fix this issue, then kindly share your experience with me through your comments below. Thank You…

9:44 am

One response to Fixed: Swipe to Delete Mail Not Working on iPhone, iPad

deleted and re-added gmail and now getting error message "the following accounts have erroes: gmail and [email protected]. Please select the individual accounts to see more information." There is nothing to click on to add imap/stmp, for instance, when i click on the account. Now i am not getting any mail. please help!

Leave a Reply