Fix: Powerbeats not charging


One of the newsreaders used her power beats for 4 weeks without any problem. Now they didn’t work. She tried to switch them on but it doesn’t work.  Once I put power beats for charging but the red light blinking several times. Here are some solutions to resolve the charging issue.
Solution 1: (Suggested by BLeslie)
Contact Customer Service. They asked to send them Powerbeats. After inspection, they have now sent me new ones. Seems like there is no other fix than exchanging them for new ones.
Solution 2: Download the Beats Updater
beatsupdater
Download the Beats Updater from the following link http://your.beatsbydre.com/ . and then run it to resolve the issue.
SEE ALSO: Fixed: iPhone Keeps Beeping when Charging
Solution 3: Update the latest firmware of your beats product
Both pairs of the headphones had the following:

  1. Only ever used the USB cable provided by Beats (Apple) – and only plugged into my 2011 MacBook pro USB port.
  2. Tried rebooting the device, and I have the latest firmware (the updater says Software is up to date).

In both cases, the device simply stopped charging after 4-6 weeks of regular usage. The red light comes on and pulses like it’s charging, but it stays at 0%. This happens no matter if I reboot the device or not. I have tried both USB ports on my Mac and I’ve confirmed both USB ports are working fine.
If you knew any other solutions about “Fix: Powerbeats not charging”, inform us using comment.
 

10:38 am

2 responses to Fix: Powerbeats not charging

good afternoon my beats x when charging has the red light flashing non stop I tried everything from rebooting it and nothing it still does the same thing please help.

I had a similar issue with the powerbeats 2. After ordering and replacing the battery they worked again but only for the lifetime of the battery since I let them die testing the lifetime of the new battery. Once dead they would not charge. After a lot of trial and error with different charges and cables I ended up abandoning them.
After about a month I was going to take them apart to see if I can figure something out since I'm techy. I decided to give them a try and plugged them in. Surprisingly they charged to full and the led went from red to white. They worked perfect as I kept charging them.
Well just recently, they died in me for the first time. I have not been able to charge them since so I will abandon them and try in about a week or 2.
I assume its not the battery since I got them working and worked until I let them die. I believe they drained helping the charging mechanism to accept charge. I really doubt it's the battery or the USB port on the headphones. I also doubt it's the wiring. I'm blaming the software or computer inside the headphones. I bet if I didnt let them die they would be working right now. Maybe this will help some of you. Maybe there's a pattern here.

Leave a Reply