OneNote for Mac won't allow sign-in? Here's how to fix it


After downloading OneNote for Mac, some users not able to sign into the app using their Microsoft account.
They received the following error message.
“We were unable to sign you in. There is a problem with your Microsoft account. To fix this sign into account.live.com from a browser.”
Solution (Suggested byMicrosoft OneNote team)

  1. When you try to sign in to your Microsoft account live.com from a web browser, on the top left corner, you can see a down arrow (next to ‘Outlook’).
  2. Click on the down arrow and choose OneDrive from the drop down menu.
  3. You can see the OneNote notebooks under the folder “Documents”. Click any one of the notebook.
  4. Now your Notebook opened online.
  5. Right click in the top center and choose “Open in OneNote”.

SEE ALSO : How to fix OneNote for Mac crashes on startup
Some users reported, after clicked “Open in OneNote” option, they can see the progress bar but getting the “Can’t set up notebook” error message.
If you find any solution to fix this issue, do let us via comment.

6:48 am

3 responses to OneNote for Mac won't allow sign-in? Here's how to fix it

Still does not work. One note asks me to login and when I do it keeps loading and never goes through even when I have a great internet connection

Same thing here (April 2018). I have the Office for Mac 2016 package, which included OneNote. I'd never tried it before until the other day. I don't even want to use it while synced across devices; I just want to use it to store files locally. But I can't even create a local notebook without signing in… which I cannot do.
I can sign into OneDrive with my email and password. So the email/password combo definitely works. I've tried deleting the keychain access entries, restarting, and trying to sign in again. Yet no matter what I do, the only part of this seemingly great program I can use is the splash screen. I've tried the above, and that does nothing as well. And Google is no help; I've viewed a number of links found on Google with no success. The only thing left to try is to call Microsoft, but it seems other people have already and have spent hours on the phone, and still the problem does not get resolved. That is my last untried option. So far, this program fails in comparison to Notepad.

Leave a Reply