How to fix “CoreTelephony Trace File error” on Mac


Some Mac users reported, they getting “CoreTelephony Trace File error” error message in each reboot after they login.
When this error message appears?

After you install your new SSD hard drive and using it as a primary drive for iMac or MacBook Pro, this issue happened.

CoreTelephony Trace File error

Solution 1:  Choose the location for user folder

  1. Go to Apple menu -> System Preferences -> Users & Groups. Click the lock icon to unlock it (If it ask username and password, enter admin username & password).
  2. Right click your user account for Advance options.
  3. Select the location of the user folder (Even it was in the right/same location).Mac user folder location preference
  4. Restart your system.

Solution 2: Change the sharing permission to read & write

Navigate to /private.  Right click it -> Get info -> Sharing & permissions and change it permission to read and write.

Solution 3:  Just change the /tmp/ folder permission

This issue sometimes happened because of the permission problem.

  1. Open Teminal.
  2. Type the following command sudo chown root:wheel /tmp and click Enter. You may need to enter your login password.
  3. Now type the following command sudo chmod -R 777 /temp and click Enter. You might need to enter your login password again.
  4. Exit Terminal app and restart your system.

Solution 4: Create /tmp/ folder

You mistakenly or accidentally removed a directory named “/tmp“/. So you need to manually recreate this directory.

  1. First manually create this directory.
  2. Then open Terminal and type,sudo chmod 1777 /tmp to give right permission settings.

Solution 5: Upgrade your Mac system OS to macOS Sierra

Lot of Mac users reported that upgrading their computer OS to macOS Sierra solved the issue.

If you knew any other solutions to solve “CoreTelephony Trace File error” on Mac, inform us through comment.

9:05 am

34 responses to How to fix “CoreTelephony Trace File error” on Mac

So I am confused about solution no. 1
I have a macbook air 2015 13 inch
el capitan version 10.11.6 (15G31)
2.2 GHz Intel Core i7
8GB 1600 MHz DDR3
Intel Graphics 6000 1536 MB
I get this message “CoreTelephony Trace File error” on each profile I login to just started a few days ago
I updated to the newest OS update and still getting the message
I don't quite understand your solution 1
what lock are you referring to
and which advanced options we don't seem to share the same menu
I clicked on the apple icon in the left hand corner of the screen and open system prefs but after that I don't understand the description because they don't match
I can't right click I just have the mouse pad on my macbook not sure what that means
there's no lock icon
and there's no advanced menu?
please advise

Hi

I have a similar error message while starting up the iMac. The difference is "details 'error opening file /tmp…"
All of the Adobe CS6 programs shut down while opening.

whole error message:
"coretelephony trace file error a file operation for coretelephony tracing has failed, you may be out of disk space. details 'error opening file /tmp/ct.shutdown, err = operation not permitted"

What can I do for solution 3 and 4 instead of the above?

Thanks in advance

If you try and fail on solution 1 and 2 and you know /tmp is not deleted trying options 3 wouldn't work neither
because El capital's S.I.P (System Integrity Protection) that won't allow you to change permission on that folder and will return you a error saying:
"chown: /tmp: Operation not permitted"

It seems that Sip must be disabled first via recovery mode but sounds kinda scary to do

I had this same error after the last el captain update, after trying the whole list I gave up and upgraded to Mac OS X Sierra and the problem seems to have gone away.

I'm getting the same problem.

First: I have not installed a new SSD… I don't even know what one is or why I would want one.

Second: I tried solution number one and two with no result. No idea where 'terminal' is located or how to open it. I have no computer training and no clue as to what any of solution 3 or 4 mean or how to do it.

Sorry but it's very frustrating. Is this a real issue or not? Do I have to worry that my MacBook needs replacing? Can't really afford one or afford to get repairs either.

Hey! Did you get a solution to this? I'm experiencing the exact same issue right now. Would help if you're able to let me know how did you solve this issue! Thanks so much!

What do you do when it says chown: / tmp: Operation not permitted?
How to solve the issue when that happens? Hope to hear a reply from you soon! I'm facing the same situation 🙁

I'm getting the same problem can not open adobe illustrator with MacBook pro from 2015 en Os X El Capitan 10.11.6

I don't understand solution number 2 – what is the /private? Is that in the users home folder, is that a folder, what is that?

Resolve issues caused by changing the permissions of items in your home folder
https://support.apple.com/en-us/HT203538

This will work for Lion and greater:

Reset permissions
If the issue occurred after changing the permissions of items in your home folder, follow these steps to reset the permissions:

1. From the Finder menu bar, choose Go > Home. Your home folder opens.
2. Choose File > Get Info. An Info window for your home folder opens.
3. If the “Sharing & Permissions” section at the bottom of the window isn't open, click the triangle in that section to open it.
4. If the Lock button at the bottom of the window shows a closed lock lock , click the lock and enter an administrator name and password.
5. Click the Action menu in the bottom corner of the window, then choose “Apply to enclosed items.” Click OK to confirm the action. A progress bar appears at the top of the window.
6. When the progress bar completes, open the Terminal app from the Utilities folder of your Applications folder.
7. Paste or type this command in Terminal, then press Return:

diskutil resetUserPermissions / `id -u`

On U.S. keyboards, the ` character is just above the Tab key. After entering the diskutil command, if Terminal says that permissions reset on user home directory failed (error -69841), enter chflags -R nouchg ~, then enter the diskutil command again.

8. When the process completes, quit Terminal.

JohnP, there is nothing wrong with your hardware, this is a software bug. Given your level of computer expertise, I recommend taking the unit to your local Apple Store. Make a Genius Bar appointment online and make sure you have a full backup of your data first. Apple will likely do a reinstall of your OS, which should leave all your apps and documents in place. This is a free service from Apple, take advantage of it.

I had also a CoreTelephonie Trace File Error, but not with error=File exists (like the beginning of the blog, but with error=Operation not permitted, like the other users)
A solution, which worked for me, is what DennisCrimson was describing in apple support communities: https://discussions.apple.com/message/30822043#message30822043
(He was just Disabling SIP (rootless) and than restarting). Also for me, just disabling and restarting helped.
But pls. don't forget to enable SIP again, with the same steps, just using "csrutil enable". Even after enabling again, the error was not reoccuring.

Some more details: My problem was:
CoreTelephony Trace File error
„A file operation for CoreTelephony tracing has failed, you may be out of disk space. Details 'Error opening file /tmp/ct.shutdown, err = Operation not permitted“.
This happend without a (for me) recognizable cause. Never had the issue before, no changes in hard or software.
Just the automatic download of Sierra was happening before, but I was not installing it, I'm still on El Capitan. Also an automatic update of Avira happened. I have an SSD, but already years ago, so no changes here. So no real obvious reason for such behaviour.
In one blog, it was mentioned, that this is an issue with the permissions rights and could be corrected with OnYx ("Maintenance" -> Permissions-> Execute") (or manually with 'sudo chmod 1777 /tmp').
So I installed OnYx and executed Permissions. This should fix all Permissions Problems.
In my case, it was showing and correcting a lot of permission problems, but for /tmp, Onys was still showing an issue and that it could not correct it. As I was running Onyx while SIP was enabled, I disabled it, with the intention to run than Onyx again. However, directly with the reboot after disabling SIP, the errormessage was gone. So I enabled SIP again, the errormessage was not repeated.
Lateron, even as the error was not repeating, I anyhow disabled SIP again, ran the Permission Maintenance on Onyx, and Onyx could correct the remaining permission problem with /tmp.

So my recommendation:
1. Reboot your Mac into Recovery Mode by restarting your computer, holding down Command+R until the Apple logo appears
2. Go to Utilities, than Terminal. (So don't recover your complete system, even if the window for this is located prominently in the middle of the screen and you have TimeMachine installed (I was doing it as the first thing, when the issue appeared. It took hours and was not helping at all))
3. In the Terminal window, type in 'csrutil disable' and press Enter.
4. Restart your Mac.
If the errormessage is gone after restart, than do step 1-4 again, but with "csrutil enable".
If the errormessage is again coming up, download OnYx from http://www.titanium.free.fr, execute there:
"Maintenance" -> Permissions-> Execute" (still while csrutil disabled). This should solve any possible permission problems

For JohnP: Follow step 1 and 2, to access terminal in recovery mode.
For Lynn: "Operation not permitted" indicates a permission problem, so solving possible permission problems with OnYx should help (in SIP disabled mode). Simply starting while SIP is disabled helps, if this was a one time problem, like in my case.
For Deth: yes, disabling SIP sounds scary, so execute only when your virus protections system is updated, you might want also to disconnect from the net during the time it is disabled. And enable it directly again afterwards.

For me, the solution worked, but its still scary to solve the symptons, without understanding the root cause for its first appearance.

Hey,
got the same problem right now.
Adobe CS6 programs won't start also.
I have tried fixing permissions from /tmp and /private/tmp (with disabled SIP), but no success.
OS Upgrade to Sierra has fixed the problem…

I can confirm that solution 2 works as long as System Protection is disabled. Here are the complete steps:

1. Reboot holding cmd-r to enter Recovery Mode
2. Open Utilities > Terminal and type csrutil disable
3. Type reboot and boot normally
4. Open Finder and view as columns (cmd-3)
5. Choose Go > Go to folder, enter /private and click Go
6. Right click or control-click on the /private folder and Get Info (cmd-i)
7. In Sharing and Permissions, system should be read & write, wheel should be read & write
8. Do the same for the tmp folder inside private, except this time also change everyone to read & write
9. Reboot holding cmd-r to enter Recovery Mode
10. Open Utilities > Terminal and type csrutil enable
11. Type reboot and boot normally

Is it possible Apple has infected El Capitan with this new error, to force upgrade to the new untested Sierra?

It's really, really annoying.
Did my best, but it doesn't work.
And its a NEW Mac!!!
Even cannot open Photoshop or InDesign any more …
Cannot work anymore, Shit!!!
And my IT-guy isn't available till Monday …

I,m getting the same problem with use Boot Camp install Win10. (Now already solved.)
I guess it was ( After you install your new SSD hard drive ).
I just according to do Solution 4 (and also before into Recovery Mode to close SIP and finishd open).
The message suddenly no longer appear. :)

But, my Android Studio also cannot emulator —–>failed to open a temp file
(/tmp/android-username/8de660xxxx(address code)/ for writing)
I search the Internet find same friend also cannot open some App (ex: PS.CS…) that like related.
In short, this "problem" confused me two day until find this page and see up –>dachrist speak:
"Update the OS Sierra" after problem was resolved..(what??!!)
wish helpful others .
sorry my english is very no good 🙁

Thank you dachrist the problem is solved upgraded to Mac OS X Sierra and the problem seems to have gone away

iMac – late 2015 El Capitan – a WHOLE 5 months old. my error details: 'Error opening file / tmp/ct.shutdown, error = Operation not permitted' . I spent 4.5 hrs with 3 different Apple support techs – one of which offered all of the solutions above and then referred my ticket to an 'engineer'. because nothing would fix it. So – 2 days later – yet to hear from said engineer. This thread put me on a path. I couldn't do the option of installing Sierra since it is having issues of compatibility with Photoshop CS6. So I tried the 'RE-installed El Capitan from Recovery Mode' . All the errors went away and I didn't have to reauthorize any software. Everything seems to all back to normal. I left the PC world 10 yrs ago because of Blue Screen of Death – This is the FIRST time I've ever had an issue with Macs.

I tried all the solutions but none of them worked for me. Then I discovered the problem was related to the permission to write on the /tmp folder (at least in my case). That led me to disable the System Integrity Protection feature that Apple introduced in El Capitan and the problem was gone. However, it is not a good idea to disable SIP forever, so I followed the instructions on this thread to delete and create a new /private/tmp folder.
http://superuser.com/questions/1133065/unable-to-write-to-tmp-osx-unable-to-correct-permissions-operation-not-permitt#comment1629612_1133065
ATTENTION: the rm command cannot delete a non empty folder. You must add the flag -r. In other words, step 4 should written like this:
sudo rm -r /tmp
sudo rm -r /private/tmp
It worked like charm for me. No CoreTelephony message since. It also solved the problems I had with several applications that use that folder and couldn't write in it. As what caused the problem in the first place, I have no idea. All I can say is that it all started after I upgraded to El Capitan.

Techmom – Your fix (Re-installing El Capitan) worked to eliminate "Core Telephony" error which was preventing use of CS6 Illustrator, Photoshop and InDesign on my 4-month old iMac…THANK YOU SO MUCH!!! NOTE" It takes several hours to download and re-install after re-booting in Recovery Mode, but so glad that the Fix worked. Apple (if you see this) I will be VERY disappointed if this bullshit exercise was a pre-planned ploy to force MAC owners into upgrading to OS X Sierra?!

I truly think this is a forced upgrade. I heard – thru an Apple Senior Tech Support person – that they are NOT going to fix El Capitan and Sierra is the fix.

Tried this and it didn't work for me even though the process completed in terminal. my issue comes up as: coretelephony 'error opening file /tmp/ct.shutdown, err = operation not permitted ' and it prevents me from shutting down or restarting the computer unless I do a hard reset. This also prevents me from being able to upgrade the OS to Sierra.

When I reboot in Recovery mode it just shows me that it wants me to turn on my keyboard and my mouse even though both are connected via USB cables. So I cannot proceed any further than that…. Any ideas?

I do not understand any of this. I am not computer savvy. I also have El Capitan, 10.11.6. I get the CT trace file error each time I log on. My question is if I just leave it alone, as it disappears on its own, will I be damaging my iMac desktop?? I am leery of upgrading to Sierra, as one post noted it is untested. Thank you.

We had this problem with several of our machines. We tried the fix on a few of them. It got rid of the message, but then we could not update any of our third party apps (Microsoft, SMART, etc).

We upgraded them to Sierra and the problems went away. So far so good.

Just found out that lack of free disk space can cause such a problem. Maybe worth adding cleanup disk as another solution.

Leave a Reply