Fixed: Unable to download applications – iPhone, iPad and iPod

When users try to download free app from App Store or try to update apps, they getting “Unable to download applications” error popup.iPhone 6, iPhone 5, iPhone 4s, iPad users can’t download apps. Sometimes this issue happened after new iOS update.
Solution 1: Change the DNS address
In WiFi settings, change the DNS to,
Make sure your iOS device have enough space to download apps.
Solution 2: Change the Date and try to download app
Navigate to Settings ->Genera -l>Date and Time ->Set Automatically ->Off and set the date one year ahead.
Now try to download app. If you get the error again, go back to the settings and set the right date.
(set automatically). Then try to download the app gain.
Solution 3: Reboot iPhone & iPad
Press and hold Sleep button and Home button together for 10 to 15 seconds until Apple logo appears.
Solution 4: Sign Out and Sign in Account.

  1. Navigate to Settings ->iTunes & App Store ->Apple ID.
  2. Tap your Apple ID and sign out.
  3. Restart the iPhone or iPad or iPod. Press and hold down the sleep button until red slider appears and slide to turn off. Then press the sleep button until Apple logo appears.
  4. Then navigate back to the Settings ->iTunes & App Store -> and sign in your account.
  5. Then try to download app.

If you knew any other solutions forĀ Unable to download applications error do let usĀ via comment.

3:39 pm

11 responses to Fixed: Unable to download applications – iPhone, iPad and iPod

I just tried all of these. I can download some apps and not others. And the ones I can't download on my phone, DID download on my iPad mini, all download on my cellular service but changing the DNS to did not work. I thought it would because at the apple store, I connected to their wifi and could download them there.

Same here. I erased my iPhone and updated to newest ios version but still cannot download any apps. After changing the DNS, it finally worked. I thought my phone would be useless since there were no apps installed except for the default ones.

I tried all the above solutions but still I am unable to update & download any software please suggest me what can I do now

Checked restrictions, power cycled, changed to google dns, soft reset, signed out/ into iTunes, checked storage, tried wifi and cellular… no resolve.

Leave a Reply