Fix: Can’t Delete iPhone, iPad Apps – X Symbol does not Appear

 

A lot of iPhone users reported when they try to delete apps (Press and hold the App icon) X symbol does not appear on the upper left corner of the app. It’s really an annoy. Here, you can learn to delete apps on iPhone, iPad without an error.

Solution 1: Choose Allow to Delete Apps

If the delete apps option is not allowed on your iPhone, then you can not delete the apps and won’t get the x symbol.

  1. Go to Settings.
  2. Tap on ScreenTime and click the Content and Privacy Restriction.
  3. Enter the passcode if asked.
  4. Then select the iTunes and App store purchase.
  5. Click the Deleting apps and now choose the Allow option.

 

choose the delete apps

 

Solution 2: Try to delete App

This trick will help you to solve the problem on your iPhone/iPad. So try this one.

  1. Lightly press and hold the app icon you want to delete (not the screen). Hold 3 to 4 seconds until app icons wiggle and X symbol appear.
  2. Click the x symbol to delete the app.
  3. Press the Home button to return iPhone home screen.

lighty press and hold the app icon

 

Solution 3: Turn off Restrictions or only Enable Deleting Apps option in Restrictions

Many of the users suggested doing this method, they said this method has worked for them. So you can also try to resolve the problem.

  1. On your iPhone, go to Settings -> General -> Restrictions.
  2. Type the Restriction passcode.
  3. Then turn Off the Restrictions.
  4. And again type the passcode.
  5. Now go back to the home screen and try to delete the apps. The X symbol will appear on your app icon.

or

  1. Navigate to Settings -> General -> Restrictions
  2. Type the passcode.
  3. Check if the “Deleting Apps” option is turned off or not. If it’s turned off, turn it on.

Solution 4: Delete Apps using another Method

On your iPhone or iPad or iPod Touch, try this another method to delete the apps. To do that,

  1. Go to Settings -> General -> Storage & iCloud Usage -> Manage storage.
  2. Choose the app you need to delete.
  3. Select the Delete App option.
  4. Confirm the Delete app option.

Delete Apps using another Method

 

Solution 5: Restart the iPhone

The above solution is not worked them follow this method. For that,

  1. Press and hold the Sleep/Wake(Power) button until the “Slide to Power Off” option appears.
  2. Drag the slider to the right to turn off your device.
  3. Wait 15 seconds and turn on your iOS device again by pressing the sleep/wake button(power button).

resart the iphone

 

That’s all. If you know any other solutions to fix the “How to delete apps on iPhone or iPad that won’t delete” issue, tell me in the comment. Thank you…

Leave a Reply

Your email address will not be published.

Related Posts