FileVault stuck on "Encryption Paused", fix : Mac OS X Yosemite

After upgrading MacBook Pro to OS X Yosemite, the encryption get stuck.
In System Preferences -> Security & privacy panel, it shows “Encryption Paused” .Connect power adapter to resume encryption. But users already connected the power adapter.
Filevault stuck on Encryption Paused
Rebooting, Resetting SMC & PRAM does not fix this issue.
Solution 1:-

  • Restart your Mac Book Pro.
  • Reset PRAM with option+cmd+p+r.
  • Boot with cmd+r (immediately hold down) for utility disc.
  • Select the partition encrypted  -> Click file and unlock  -> Repair the partition disk -> Repair permission on partition -> Repair macintosh hd
  • Restart

The encryption might resumed.
Solution 2:-
Use Disk utility in recovery mode.

  • Reboot your MacBook and hold Command+R at the startup to run the Recovery Mode.
  • In OS X tools panel, open Disk Utility.
  • From the sidebar, select your boot drive and choose the unlock button. Enter your Filevault password to unlock the drive.
  • Hold the command key, from the sidebar select both unlocked volume and drive device.
  • Navigate to First Aid tab and choose “Repair Disk” option.

Then Reboot your Mac.
Other Solutions :-

  • Backup your data first. To forcefully disable filevault, open Terminal app and type the following command  “sudofdesetup disable" . If its disabled, the encrypting bar should move.
  • Repair both disks using command + r. Shut down and hold shift+control+option+power (for 20 seconds). Restart it with you adapter.
  • Plug in the Macsafe power connector. It might change the progress bar from ‘paused’ to ‘encrypting’ in your MacBook Air.
  • Open disk utility and select your drive. Click File. Then Decrypt Drive. This will start decrypting the drive.

If your problem not fixed yet or fixed, do let us via comment.

5:06 am

13 responses to FileVault stuck on "Encryption Paused", fix : Mac OS X Yosemite

Solution 1 didn't solve problem. Solution 2 did for about 3 seconds then, encryption bar said paused again. I cannot get machine to recogise the command sudofdesetup disable (one space?).
If I try disk utility the choice to decrypt is greyed out (under other solutions).
MBP retina display 2015, Yosemite
Any help appreciated

Update to above. I tried solution 2, once again, and Filevault changed to 'optimising', then stopped on pause. Tried once again, and eureka, it finished encrypting. Seems to be working fine.

Solution 2 did the trick. I found many different suggestions in other threads. Mostly something with a complete reinstall. But I am glad I tried this first. It took 20 hours to optimise the encryption though and another 2 hours to disable it. Now its off 🙂

GD!!! When will Mac/Apple fix this GD problem? Solution 1 didn't work.
Solution2 worked…or so I thought all the way through to …Optimizing 5 Seconds left…than back to firkin Encryption Paused!
FIX IT…I bought this MacBook Pro today! and Im hung up on this damn problem which seem to have been around for MONTHS!!!

Strange fix I discovered today. When I open the FileVault view in Preferences (OSX Yosemite) and check status while simultaneously running Disktools and Verify Disk, I see the progress indicator advance for FileVault. I had been stuck at 47.81% for 5 days with no progress.
I happened to run 'diskutil cs list' while Verify Disk was running in the DiskUtils. The command actually shows progress in the encryption while verify is running. It appears Verify lifts the lock or pause on the volume while it verifies the disk and allows Filevault to progress with its encryption.
This got me thinking… If I can loop a disk verify, I can complete my encrypt. SO I gave it a try…
bach -c 'while [0]; do sudo fsck_hfs -l /dev/disk1; sleep 4;done'
This command loops the disk verify from the terminal command prompt and allows FileVault to make progress. In the course of 5 minutes, my status went from 48% to 55% encrypted. My Security and Privacy tab in Preferences / FileVault showed a status change of Estimating Time to now showing 2 hours remaining.
Finally, some progress.

Hey CGrossmeier, I don't quite understand your command.
bach -c 'while [0]; do sudo fsck_hfs -l /dev/disk1; sleep 4;done'
There is no bach command, do you mean bash? and if so, it already is in bash mode is it not? If you could walk me through how to loop a disk verify that would be great. Thank you.

This was happening to me on El Capitan when plugged in to a Thunderbolt Display's power source — which uses that little power adapter for newer MacBook Pros. Switching to the laptop power cable fixed the issue without having to try Solution 1 or 2.

I was able to fix my MacBook Pro on Yosemite by repairing the disk using Disk Utility while booted into macOS Sierra installed on an external hard drive.
I tried repairing from recovery many times, but it did not work until I tried to repair from macOS Sierra on an external drive. When I booted into Yosemite on internal drive after the repair completed, it showed FileVault as On and it was no longer waiting to encrypt or paused.

Leave a Reply