How to fix Apple TV blinking, but not responding to remote

Apple TV suddenly stopped responding to the remote (sort of).
When users push the play/pause button, it turn on. But after it boots up to the main options page the Apple TV remote no longer works and cursor stays in the same place.
When users push the buttons, Apple TV blinks white light which indicate the functions work normally.
Unplugging entire Apple TV system and rebooting it not solve the problem.
SEE ALSO :ย Apple TV remote not working? Hereโ€™s how to fix it
So how to fix this issue?
Try to unpair and repair Apple TV remote with Apple TV

  • Press and hold down Menu and back arrow button simultaneously for 10 seconds.

Note: If its not solve your TV problem, you can temporarily use your iPhone, iPad or iPod as a remote using remote app.
Also read Apple support guide: Resolve Apple TV 2nd and 3rd generation issues with remote.

9:23 am

16 responses to How to fix Apple TV blinking, but not responding to remote

Thanks so much… I am happily back in Apple Tv land… Remote was the issue… Your advise was dead on… If you are ever in the Baltimore area the first drink is on me…
Regards… Stu

Man I had the exactly same issue and your trick saved me!!!!
Thank you very much I was about to send it back to Apple.

Great trick / fix! Been pissy for a week thinking kids did something wrong, Netflix here I come!!! Thanks for the how to…

thanks so much. this worked for me as well ๐Ÿ™‚ .. too bad i thought it was the battery and spent 6 bucks on new ones.

Remote is working. Apple TV keeps glitching. Coming on and off. Tried to hold the menu and – at the same time. Have a black remote. Apple logo doesn't come on. Don't want to unplug everything. Help!!!

Your repair worked perfectly. This has never happened before, so now I know. Thanks. Other repair suggestions didn't do it even though they might have been well thought out and presented. Yours was simple and got the job done.

I spent all morning reading and looking on youtube_. Spent 10 second reading and doing what you said n right on itโ€™s working now, THANKS

Leave a Reply