How to Fix Apple TV Cannot Connect to iTunes Store Issue

Some times users try to connect Apple TV to iTunes, it shows error message like “unable to sign in” “Cannot connect to iTunes Store” or “Apple TV can’t connect to the server at this time. Please try later”. Also some times Apple TV display none of the normal icons.
So users cannot watch or listen to iTunes movies, TV shows, music and podcasts through Apple TV. This problem might happened after Apple TV update or server issue.
Solution 1:-
Press or hold down Menu and Down Arrow keys together (at the same time) for 6 seconds until the light flashes rapidly.
This solution solved so many Apple Tv users issues.
Read Also: How to speed up your  Macbook.
Apple tv can't connect to the server
Solution 2:-
Try to logout your iTunes account on Apple TV and log back again.
If you try to log back in, it remember your Apple ID and require to re-enter password.  After do this thing, check the iTunes connection.
Solution 3:-
Do system Reset to solve this problem.
Solution 4:-
Unplug Apple TV and plug it back again. (This solution solved some Apple TV users issue).
Solution 5:-
Go to Settings->General-> Region
Change from default to your country like us, uk (where you live).
Then Restart.
Solution 6:-
This problem might happened because of automatic (DHCP) address and DNS assignment not working. So enter IP address, gateway and DNS settings manually.
If you knew any other solutions, do let us via comments.

8:55 am

59 responses to How to Fix Apple TV Cannot Connect to iTunes Store Issue

I finally fixed it!
I connected my ATV via my iPhone instead of the router. After setting the correct region and connecting to iTunes, I switched back to my normal network. All set 🙂

Yes! I tried ALL other tips, even on phone with an apple rep and NONE of them worked- reset, update, unplug, reset router, hold down buttons, all of them and could not get tv to let me sign into iTunes. Rep even made me an appointment to take to a store for service. I went to store and was told since it was on older (2nd or 3rd generation?) ATV, in order to fix it it would cost as much as buying a new one. So I said forget it & brought it home. It sat on my kitchen table for about a month- until today, when I saw this…… I plugged it back in, got the remote app on my phone, set it up, logged in with phone "remote" and WHALLAH!!! It worked!!! Rep & store tech NEVER suggested this! Now I can use regular remote and all is business as usual!!! I did make sure settings were correct time zone & country also- that may be important, rep & tech never mentioned that either. Thank you thank you THANKYOU!!!!

Unfortunately none of these worked for me…im at a loss. It just says "cannot sign into iTunes" been trying for 2 days and still no luck

I tried all but a complete system restore and still had problems with signing in.
I managed to use the "remote" app on my iPhone. After 5mins the Apple TV finally displayed in the app!
I then went through the sign in steps for all actions – iCloud, iTunes and home sharing and everything worked!

Stupid apple tv .. It keeps saying before I can make purchases I must go to the iTunes store on my computer and verify your payment information … I've updated and saved the info 3 times now and it still just gives the same message … This is going to work or it all goes back and I hook up my VERY easy to set up ROKU box, once again …

Heres another solution if none of the above worked for you, simply access your router via ip address and restore it to factory settings as well as your apple tv

This sucks. Apple you suck. I restarted the device and now I get nothing. What a piece of shit apple has turned into.

my apple tv is blinking non stop and isn't showing any picture on my tv. i tried plugging it into my mac but its non recognizing the apple tv in my itunes ! anyone know how to fix this? need help asap

Nothing has worked the issue out for me. It's really disappointing.
the error message is:
Apple TV cant sign in to the itunes store until the network time has been set?

None of these worked on 2x Apple TV . Both saying cannot connect to iTunes. I knew I had a good internet connection so simply mirrored my iPhone to the Apple TV and then like magic, it all came back up! Went to the other Apple TV box , did the same thing and again, all back up!! No idea why but as didn't see this tip anywhere else, thought I should post it

None of these Worked. Apple is just a bullshit. This is why i keep buying Sumsung items. They are best in everything from the service to the prices. I usually buy 2 to 3 phones a year and since now apple are loosing 5000$ a year i wont buy anything from them and wont let my kids buy from them. Good bye

Hi I'd just like to contribute if anyone else is reading this and still cannot solve it.
I tried a tip and that was to "Airplay" my iPhone against the Apple TV, that was all that was needed, when entering the settings after that Everything was up and running…
Best Regards Thomas

I tried Everything including factory reset, hold down menu and Arrow down until it starts blinking, mooved it so I could use eth Cable. set static ip manuel et of google dns. Then I just tried to mirror my Iphone against the apple tv, saw my iphone on the tv and when exiting that the Apple tv started to act normally.
Best regards Thomas

I try everything in the list, then Airplay with my Macbook and nothing worked! Then I tried to airplay my iphone6 against the Apple TV and it worked!!
Best Regards,
Dani Merc

Wow, I've had this problem for months now, and today I decided to give it one more chance by searching around. I've tried probably everything, but this fixed it in three seconds. Thanks alot!

My Apple TV worked fine. I went on vacation and when I came back all the apps were gone and the apps meny is gone. Tried to connect, but it is only saying "Can not connect to the Apple Store." Very frustrating. I´ve tried all the solutions suggested, including mirroring the iPhone. Nothing works. Sad to say that Apple disappoints.

Solution one worked for me. It wasn't connecting to iTunes or my Apple Watch for remote. After holding menu and down for 6 seconds and then signing back into iTunes it was working fine again.

Wow! This blog looks exactly like my old one! It's on a completely different topic but it has pretty much the same page layout and design. Excellent choice of colors! bccddbfdfkcbecec

None of the solution worked for me ? This is beyond stupid how can it work one min when u get it and the 2 weeks it not work. Apply tv beyond a joke in my experience. Dislike

I found that powering down and then back for my broadband modem, then restarting my airport extreme, and finally settings->general->restart to my Apple TV solved the problem.

Hi folks,
I'd like to tell you that the soluion 6 works fine for me. For any reason there were a problem with the IP address assigned by DHCP of my Router. I assign one manually and that works.
Thanks for help me.

I tried everything and it worked thank u random person this is Jennifer Popez this dude is awesome listen to his ideas and siri and ask siri to beat box for u and ask siri what does the fox say and once again thank the world and rainbow Bob good bye

Many thanks. Spent hours trying to sign in to Apple TV. Solution No. 1 worked right off. You are a genius. You should be running Apple.

I have over $100 in my iTunes account and when I tried to rent a movie on apple tv I was asked to update my billing account. What's up with that

My problem is a little different than what I've seen here. Everything good until today when I suddendly cannot play episodes from purchased tv shows. All the apps are showing, it's only when I click play a particular episode that it gives me "error loading content". Netflix plays fine. When I tested my network it told me it can't connect to the Apple Store. I've tried everything including signing in and out of my account, short of a factory reset. I mirrored my iPhone to the Apple tv and unmirrored it and it doesn't work. Basically, Everything is there, but when I try to play any content bought through iTunes, it will give me this message. Has anyone had this particular problem?

This happens to me pretty much anytime there is an iOS update to my Apple TV. The only way I can get it to connect again is by doing a hard reset.
So frustrating.

Just want to confirm that I had the same problem – no apps and no connection to iTunes Store on Apple TV gen 3.
I tried reset, using Ethernet cable, eventually restore to no avail.
I saw the suggestion of mirroring iPhone to Apple TV and thought it was a bit ridiculous, but tried it and after turning off mirroring all the apps are immediately back and can connect to iTunes Store.
I don't understand why this would work, but it did for me.
Might try this earlier next time!

I tried all those too. I ended up signing out under settings of my iTunes account on the Apple TV then added a new user which was my original. I Resigned in with everything and it worked.

Tried changing iTunes accounts, changing iCloud accts, resetting ATV, using iPhone and IPad remotes, changing regions, powering off. None worked for my 2nd gen ATV. Won't be taking my ATV to the store.
ATV didn't work with new two factor authorization.

Put in my user ID. Put in my password. Put in Verification Code. Bring me back to the page asking for my userID.
The login got me going in cycles, repeating my entries

I have tried each of these so called solutions restart, reset, reboot modem, log out, log in, remote app, powering off, new password, two factor verification. Meditation, new account, setting the region, prayer, incantations, letting it sit for months unused. I have not yet thrown it out the second story window. This really does suck.

Thank you, I tried the menu and down arrow and it seemed to be the same. But a simple log out and log back in worked with the 2-factor authentication through my iPhone.
I have an older v3 Apple TV
Model: Apple TV 3

Leave a Reply