How to Fix AirPrint Not Working Issue After iOS 8 Update

So many AirPrint users hit the issue after updating their device to iOS 8 and iOS 8.02. Users can not print anymore via AirPrint. Its showing URF error, “No AirPrinter Printer Found” error  and they cannot print with network printers . But iOS 7 users still able to print.

Use the following methods to solve this issue. This methods already solved  so many people problems with AirPrint. Also this methods are suggested by Apple community support. So you don’t need to worry about other things.

Solution 1:-

Step 1: Turn off router.

Step 2: Turn off printer.

Step 3:  Turn off iPad or iPhone using reset procedure.

Step 4: Turn on router and wait 30 to 60 seconds.

Step 5: Turn on printer and wait 30 to 60 seconds.

Step 6: Turn on your iPhone or iPad. Now try to print.

Solution 2:-

After update iOS 8.1, the problem solved for many users.

Solution 2:-

Reset the iPad or iPhone  ( Hold  down power and home key at the same time in Mac until apple logo appear).

This method working for some users. After this process the printer immediately recognize the process and page printed perfectly.

Solution 3:-

If you can’t find your printer through AirPrint, follow my steps.

Go to Settings -> WiFi settings and choose “Forget this network”. Reboot your device. Then again logged back in on the network. Your printer might detected again.

Solution 4:- Consider the following requirements to solve this issue

  • Your printer must have the latest firmware update.
  • Printer must be on the same Wi-Fi network.
  • Your router must support Bonjour.

Solution 5:- Other reasons for this problem

  • Checker if your printer has paper and ink.
  • Check your printer power on or off. Turn off your printer power. Wait some time and turn on again.
  • Check your printer if it shows any error  light or indicators on printers control panel.
  • Check  if your printer is listed in AirPrint supported list.

If you find any other issues with AirPrint, do let us via comment. Also if you have any other solutions do let us.

4:12 pm

99 responses to How to Fix AirPrint Not Working Issue After iOS 8 Update

Did not work. From what I've read online the problem is caused by iOS 8(.02). Apparently with iOS 7 Airprint used to work fine on many printers including the Samsung printer I have. Starting with iOS 8 problems started to occur. Now Samsung and Apple are pointing fingers at each other. According to Samsung, AirPrint is not a Samsung application and therefore they are not obliged to have their device working with AirPrint. The fact that it used to work (and they still advertise their printers with it) is just a nice 'bonus' then. Meanwhile I understand Apple might or might not fix the problem or just take those printers off the AirPrint compatible list. Guess who is the victim of this.. the customer. For my work I rely on AirPrint as I only use an iPad, wifi and my (used to) AirPrint compabible printer. Samsung has their own app for printing and so does Google but not all iPad apps can use that.

I have an Air printer epson xp 410 with air print.
I can get the printer to print a test page but will not print from ipad 2. Says no printer found. Is this because I am still using ios6? Shoud I update to ios 8

Success, after 2 weeks of trying! Thank you for the instructions, but why, oh why, did Apple not highlight this, in flashing lights, when you update your i pad.

iOS 8.0.2 update makes iPad 2 very slow.
So Before update iOS 8 to your iPad, read other iPad 2 users suggestions about their iOS 8 update. But iOS 7.1.2 update not make any issue in your iPad 2.

This problem may caused because of some other reasons

Your iOS Device and printer must connected to the same WiFi.
Your printer must has the latest firmware version installed.
Your printer must has paper with enough ink.
Printer control panel must be free with out any errors.
Turn off printer power and turn on again. Then check this issue.

Try to use Epson iPrint App:

Arun, thank you for your column. I just did the iOS 8 update on my iPad yesterday. I tried several times to airprint from my iPad to my HP wireless printer last night. Each time the banner on the iPad finally said "sending to printer", I waited and waited, but nothing happened. I was going to wait until this morning to begin following your solutions, but guess what? First I tried printing one more time, and it's back to working again, all on its own! So my advice is, don't panic. First, wait several hours if it's not urgent, then try again… I hate these iPad updates, and won't be doing them any more.

Hi Mo,
Thank you for your valuable comment. iOS updates always make lot of trouble in old iOS devices. If you want to avoid issues, wait some time for other iOS users reports before update.

After the latest update on my IPad I cannot print. The print icon is not showing. Can someone help? I have re-booted the IPad and also disconnected and reconnected the WFI but to no avail.

Worked like a charm, wish these instructions were on the official Apple site…thanks for taking care of us and our problems….

All ipads with 8.0 or higher can see the printer, however when the print job is sent, there is no output from the printer. I am using an HP400 M451. It was on the Airprint compatibility list prior to the 8.0 release but now it isn't. Is that b/c it will no longer work?

Airprint works for a day or so, then has to be "setup" by connecting to the printer ip address and selecting basic settings and Setup. Works fine for a day then must be SETUP again. Once setup, works great from mac, ipad and iphones. Next day, it must be setup again.
Any advice ?

I upgraded my iPad mini a couple of days ago to OS 8.1.2. My Dell B1256dfw printer is current with drivers and I'm able to print using my Dell PC. However, I cannot print with my iPad mini. I was NOT able to print just before the upgrade but was able to print some time this summer. Each time I attempt to print, the printer prints out this: URF ERROR – Incomplete Session by time out
Position = Ox1 (1)

System = h6fw_5.61/os_hook

Line = 1434

VERSION= SPL 5.61 06-13-2012

Do you have any idea what this means? (BTW, I have followed all the above stops to resolve this printing issue, to no avail.)
Thanks, Bill

Have a Samsung Xpress M2022W, with so-called AirPrint functionality, won't print: "An error occurred printing this document"… Printer keeps on trying repetitively, I get the same error message over and over again…

Solution 1 worked! Thank you. Printer was connected successfully and iPhone was connected to the network as well. It was driving me nuts. Thank you again.

IPad Air and Canon MX432. All was well TIL the updates. None of these wonderful solutions work for me. Any ideas?

Hey, I had the same problem. I have Samsung Xpress M2874FW. You need to update firmware on your samsung.

Go to Samsung homepage and find your printer. Then download the newest firmware.

Tried all listed solutions with my iPad and iPhone and Epson WF-3540. None worked. Did work prior to updates. Very frustrating. Very frustrating. It should work, everything checks out. Thanks though.

Solution one worked for me. I was having issues connecting to a HP6700 with an iPhone, iPad, and MacBook Air. Thank you!

Also worked for me with my IPad and Canon printer. I didn't turn off my router in prior attempts to fix the problem. Didn't know that was needed. Thanks so much.

I've tried all solutions and my iPhone 6 still refuses to print to my HP LaserJet MFP 476 nw. All other mobile devices, including two iPads and an iPhone 5 work perfectly on my network as well as two Macintosh computers. The one thing that I can do to print is to go to my wi-fi settings on my iPhone 6 and select the HP-Print-ae-Color LaserJet MFP network. However, it's a pain to have to switch networks each time I want to print from my iPhone.

I just bought an Epson wf-3620 so that I could use AirPrint. JimF, did you ever get it to work? I have an iPhone 5S and iOS 8.2. Ugh!

I should also add that I tried all of the solutions in the article and none worked for me. Great article, however!

Solution 1 also worked for me. Tried many times before without luck, but now it works.

I'm a bit reticent about installing IOS 8.2 though!

Can print from my mini iPad to my hp5520 printer but each time I want to print it makes me go to settings to select the there anyway to have it select the printer without going through this step and still leaving my Wi-Fi connected.its annoying but only a small problem

Samsung Xpress M2022W iOS 8 solution is to upload newest FIRMWARE VERSION : V3.XX.01.11 – no more problems with iOS devices printing from Safari or other applications.

Solution 1 worked, but didn't need to recycle the iOS device. Restarted one iPhone and one iPad but not another iPhone. All three were able to see my Epson 3520 printer after restarting the router and printer.

Mac and iPhone work, however ipad not? Tried everything but ipad refuses to find the printer.

Solution 4 worked for me, I went to my cannon MX470 series printer menu, look for firmware update and now it works perfect thanks

Hi I tried you solutions but they din't work but I do realize that I am operating on the newest operating system, but I was wondering if you had any solutions to my problems. So I have a mac book Pro and I can print wirelessly from there but I can't print wirelessly from my IOS devices such as my iPhone, iPad, or my iPod, so I was wondering if you had any solutions?

Thanks for the help, but I fixed mine by going into my Canon MG5320 and putting my password into the wireless settings.

My phone found the air printer but asked me for password and username for the printer ,I tried everything but it doesn't work at all :-(!is someone had the same issue?

Option 3 worked like a charm for me with my DELL C2665dnf printer. Thanks for an easy fix once I found my router's password again.

Get the "No AirPrint Printer found" when trying to print from either my iPad or IPhone each running IOs 8.4. Tried everything contained here and nothing works. Apple is pointing to my Canon MG6320 as being the problem. Checked and found that printer firmware is up to date. Any body have any help??

Hi Howle,
I am having the exact same problem as yourself and have tried all suggested solutions without any success.
My Air Print Canon MG 6250 used to work fine with two iPads (2 and 4) and with my iPhone 5S.but now only air prints via my iMac and an old Dell running Windows 7 Pro.It would appear that the IOS 8.4 download is at fault and not the Printer as it works fine with the remaining two(non-IOS) appliances.
Will get back to you if I stumble upon solution,otherwise will wait for IOS 9 out next month.

I tried ALL the suggested solutions ….. Nothing … I have the 8.4.1 version
My printer is HP LASERJET P1102w. Still cannot print
Can you help?

None of the solutions provided worked.

What did work was to reset all settings to default on my printer.

Then I connected to my wifi again, then my iPad found it.

My IPad AirPrint worked fine with the Epsom AirPrint compatible printer and router.After update, IPad would only find printer if I rebooted the IPad. The reboot only worked for a few minutes and only one print job. Thinking it might be the printer, bought Canon MG5320 AirPrint compatible printer. Canon allowed me to send new printer back to them and was replaced by new MG5320. After trying all the suggestions from this site without improvement, I guess waiting on next update to correct IPad is my only possible solution.

i just bought a Canon MX922 in June. AirPrint worked just fine with my iPad 5 and iPhone 6 Plus until several days ago. This is really frustrating.

On our Epson workforce SF 3520 after the iOS update to 8.4.1 the wifi MAC address was wrong on the printer. For us we had to open the Epson iprint and iPad settings and contrast and compare for the differences in wireless wifi settings on the printer. With the iOS 8.4.1 update the iPad settings are not changeable you have to change the printer settings.

After many go arounds and finger pointing, mysteriously both my iPad and iPhone now see my Canon Mg6320. Installed no iOS updates or printer firmware..very strange

Option 1 here worked perfectly. It looks like the Printer somehow had picked up a DHCP IP address that was already being used and was conflicting. Once all powered off and power back on the steps advised and new IP was found and worked great!!
Many Thanks 🙂

Right I have windows 10 and now and then I get all sorts of problems with AirPrint but the solution that works every time is to get the installer for AirPrint and run it and on the install screen is a start and stop option press stop and then press start, it works for me everytime

I had a similar problem with connecting new Canon Pixma printer.
ie it printed from laptop ok when plugged in directly via usb to the laptop.
It worked printed wirelessly from the laptop when the usb was plugged into airport express. It would not print from either of the two ipads used in my network.

Here's how I solved it:
Make sure that your printer is physically connected to the network
In my case this meant plugging its usb into my airport express box
Go into airport utility app on ipad
Tap on base station icon
Tap on "edit" link (on right hand side of base station name)
Tap on "advanced" at bottom of list of options that appear
Tap on "add WPS Printer at bottom of list of options that appear
Select either With Pin or On First Attempt.
Press and hold the button on the printer with the WPS symbol on it.
In my case this was illuminated in blue.
Wait until it stops flashing, and turns solid.
Your printer should now have joined your network, and should be able to be found when you try to print, even after you unplug the usb from airport express.
This worked for me. Took me two hours of trying. You think there would be an easier way? For me there wasn't, but it all works now (at the moment!!)
Good luck – hope of some help.

Hi again Howle and others experiencing similar problem.

Further to my posting of 6th August,please see above,I am now running IOS 9 on my iPads.
Unfortunately I am still unable to Air Print from the IOS devices.
Has anyone else solved the issue since the update please?


This happened to me again after the IOS 9 Update so I followed your instructions AGAIN in solution 1 and voila! It works!!! Thanks for posting this… So helpful?

I found the same problem with my ios devices . For no apparent reason nothing would print. On my Canon MX926 and 726. All very frustrating. I did find a simple solution that I hope may help all you people that have the same problem. Go to your apps and search (Active Print) its a free app, and download to each of your devices and bingo, hopefully you can now see you printer. Hope that this can help at least just one person. GeoffA.

Go to the app store and download the free app. Active print to each of your devices. Hope this helps. GeoffA.

Thanks for writing this, you really are a life safer. You are just so smart and your knowledge of computers is breathtaking. Thank you for being you.

If you can't tell, I'm being sarcastic.

Tried everything all solutions nothing works since ios9.1 printer I have is hp/office jet 6500 E710n please help.

Thank you for you advice, I thought I had to buy another printer. So happy it was a simple fix!!! Thanks again.

I can print just fine from 2 iPads but our iPhone 5S and iPhone 6S will not since last update. The solutions suggested did not work. Downloaded ActivePrint but it is apparently a PC app. They want another $5 to set your printers up to work with IOS devices. That would be okay if there were any guarantee it would work it hate to throw more money away on this problem.

Mine use to print with no problems, now it takes me right to google cloud print?! And if I happen to get the prompt to find a printer, it says no air printer found. I've turned everything off and on. Ugh. Any other suggestions? Thanks!!

After last update my canon mx920 showed no printer available. I thin Apple should fix this problem not us. I have tried everything suggested

I was able to print from my iPad then we had to get a new router and haven't been able to print from my iPad since . I have tried all the solutions above and still isn't working. Do I need to down load a net gear genie app to set my iPad up with the router or printer? I am able to use the internet on my iPad I just can t print it keeps coming up saying no air printer . What do I do now? Help please!

I have the same printer and I am having the same troubles! I've spent the last 3 hours trying to figure this out. I tried connecting both iPad and printer to router. I also tried the direct connect!! The canon app is telling me there are no air printers available when it shoes my canon connected! Ughhhhhhh

OMG! Tried at least 3 hours ..resetting Internet Protocol, resetting wi-fi etc etc… and Solution 1 worked! Thanks!

Solution 1 worked for me, even though I confess I didn't think it would. Thanks so much – it was driving me nuts!

After much struggles and an appt made to have PC "expert" come& fix the AirPrint setting, I googled& found your posting. While some have commented that this didn't take "great computer knowledge/skills", clearly you had more than I as I doubtfully followed directions in solution#1 for my iPhone 6 with all newest iOS updates and much older HP printer& am soooo very happy to report/–it worked!!! God bless you all for saving me at least $100 and being able to NOT stay home waiting for an "expert" for hours& solve the problem myself!!! My family thinks I'm a hero, but I'm giving all credit to you and your amazing post!!! Downturns the simple solution is truly the best and while
I'd already thought to rest phone and printer, resetting the router didn't even **occur** to me!!! You r truly a lifesaver& my "hero of the Internet"….thank you thank you!!!

Thank you so much! Solution 1 worked for me too. This has been so frustrating since I upgraded my iPhone.

You just answered your own question… You said Netgear genie…
your ipad says "No Air Printer" because you don't even Own an "Air Printer", those would be run on an apple router (Airport Extreme and such), not a netgear. Basically Kris, you need to either run a wireless printer in your house, or simply plug the printer's USB into the back of your Netgear Router

I did everything the instructions said,tried them all ,printer still doesn't work.i have an hp all-in-one wireless printer , Apple iPhone 6s and Apple iPad and Mac laptop, any more suggestions ?

This worked for me — however, today it is back to the message "no printer found"
Do I have to keep resetting?

Thank you so much. The home and power button worked for me. I went through so many other methods it was frustrating.

Unfortunately none of these fix options worked for me 🙁

The wireless print option is working fine with the laptop but not the iPhones. Very frustrating.

Hi, just got off the phone with Charter, the router they use is Netgear
but our Iphones and windows 10 laptop stopped printing once it was installed
(we still have the same printer)
"air printer not found"
we have followed all the fixes listed above but nothing has worked.

Our problem is…..we have 2 iPad mini's …..her's and mine….and when we try to connect to wi-fi direct function on our epson wf-100….mine connects and prints fine….her's….recognizes the printer connection but says no internet connection…..what is up with that?

Apple is not good son made me take his old iPhone for some reason he pays the bill but Android was much better apple just fad

Leave a Reply