Legacy Java SE 6 Runtime Popup on Mac OS X Yosemite? fix


After upgrading MacBook Pro to OS X Yosemite, lot of Mac users got this issue. If they try to open applications like Adobe Photoshop, Premiere pro, illustrator or Minecraft they got error popup message like

“you need to install the legacy Java SE 6 runtime”.

Java SE 6 on Yosemite

“To view this web content, you need to install the Java Runtime Environment.

Click “More Info…”

If they click the more info it opens a blank page.

Solution:-

This issue happened because of incompatible Java version.

Go to this page Java for OS X 2014-001  and install Java SE 6.

Click download button and install older version of Java on your MacBook Pro.

Note : If you install Java 8 on your Apple MacBook, it keep showing popup message like this. So install Java SE 6.

This problem also gone after installing development version of Java 8u25.

If you can’t run Minecraft 1.8 game on OS X Yosemite 10.10, install Java SE 6.

If you can’t download this file using Safari, use Firefox.

SEE ALSO : How to Fix USB Modem not Working in OS X Yosemite.

If you have any other doubts, do let us via comment.

2:30 pm

One response to Legacy Java SE 6 Runtime Popup on Mac OS X Yosemite? fix

Leave a Reply